Conda 23.7.4, python 3.10.13 can't install tensorflow in virtualenv

This is part introduction, part request for helpful suggestions, and part thank-you for just existing in general.

I’'m trying to get started with data science in Microsoft with Jupyter and VS Code. I’ve installed miniconda and am trying to run command trying to run command:
conda create -n myenv python=3.10 pandas jupyter seaborn scikit-learn keras tensorflow

followed tutorial almost exactly, to the letter:

I say “almost exactly” because first time I did not specify python version. I got error InvalidArchiveError(…).

Hi @g83AK49

Welcome to the TensorFlow Forum!

Could you please check the TF install official page and follow the mentioned step by step instructions to install Tensorflow in conda environment as per your system OS. Let us know if the issue still persists. Thank you.

Hi and thank you Renu_Patel,

The link TF install using

Requires the latest pip

pip install --upgrade pip

Current stable release for CPU and GPU

pip install tensorflow

worked. In conda environment “myenv” I can see tensorflow and all associated packages.

Problem solved!

1 Like