Couldn't submit Tensorflow Certificate Exam

Hi,

I recently took the TensoFlow Developer Certificate exam. I wasn’t able to end the exam because of a Java exception when submitting it. The description of the exception is below:

java.io.IOException: Error writing request body to server
at java.base/sun.net.www.protocol.http.HttpURLConnection$StreamingOutputStream.checkError(HttpURLConnection.java:3657)
at java.base/sun.net.www.protocol.http.HttpURLConnection$StreamingOutputStream.write(HttpURLConnection.java:3640)
at com.google.api.client.util.ByteStreams.copy(ByteStreams.java:52)
at com.google.api.client.util.IOUtils.copy(IOUtils.java:91)
at com.google.api.client.http.AbstractInputStreamContent.writeTo(AbstractInputStreamContent.java:67)
at com.google.api.client.http.javanet.NetHttpRequest$DefaultOutputWriter.write(NetHttpRequest.java:76)
at com.google.api.client.http.javanet.NetHttpRequest.writeContentToOutputStream(NetHttpRequest.java:174)
at com.google.api.client.http.javanet.NetHttpRequest.execute(NetHttpRequest.java:117)
at com.google.api.client.http.javanet.NetHttpRequest.execute(NetHttpRequest.java:84)
at com.google.api.client.http.HttpRequest.execute(HttpRequest.java:1012)
at com.google.developers.certification.android.engine.CertTransport.execute(CertTransport.kt:69)
at com.google.developers.certification.android.project.ExamControl.submitExam(ExamControl.kt:71)
at com.google.developers.certification.android.project.SubmitExam.run(SubmitExam.kt:80)
at com.intellij.openapi.progress.impl.CoreProgressManager.startTask(CoreProgressManager.java:436)
at com.intellij.openapi.progress.impl.ProgressManagerImpl.startTask(ProgressManagerImpl.java:120)
at com.intellij.openapi.progress.impl.CoreProgressManager.lambda$runProcessWithProgressSynchronously$8(CoreProgressManager.java:542)
at com.intellij.openapi.progress.impl.ProgressRunner.lambda$new$0(ProgressRunner.java:83)
at com.intellij.openapi.progress.impl.ProgressRunner.lambda$submit$3(ProgressRunner.java:244)
at com.intellij.openapi.progress.impl.CoreProgressManager.lambda$runProcess$2(CoreProgressManager.java:188)
at com.intellij.openapi.progress.impl.CoreProgressManager.lambda$executeProcessUnderProgress$12(CoreProgressManager.java:624)
at com.intellij.openapi.progress.impl.CoreProgressManager.registerIndicatorAndRun(CoreProgressManager.java:698)
at com.intellij.openapi.progress.impl.CoreProgressManager.computeUnderProgress(CoreProgressManager.java:646)
at com.intellij.openapi.progress.impl.CoreProgressManager.executeProcessUnderProgress(CoreProgressManager.java:623)
at com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessUnderProgress(ProgressManagerImpl.java:66)
at com.intellij.openapi.progress.impl.CoreProgressManager.runProcess(CoreProgressManager.java:175)
at com.intellij.openapi.progress.impl.ProgressRunner.lambda$submit$4(ProgressRunner.java:244)
at java.base/java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1700)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.util.concurrent.Executors$PrivilegedThreadFactory$1$1.run(Executors.java:668)
at java.base/java.util.concurrent.Executors$PrivilegedThreadFactory$1$1.run(Executors.java:665)
at java.base/java.security.AccessController.doPrivileged(Native Method)
at java.base/java.util.concurrent.Executors$PrivilegedThreadFactory$1.run(Executors.java:665)
at java.base/java.lang.Thread.run(Thread.java:829)

Can someone tell me what is wrong or indicate me a solution so it won’t happen in the future?

I had similar problems during my attempt. Could not submit.

I just installed the plugins, restarted the computer and installed it again. The exam picked up from there

Thank you so much for your help! It didn’t work for me though.
Do you know anyone I could contact?

You can try your luck by sending an email to tensorflow-certificate-team@google.com

I have tried that before and apparently that email account doesn’t exist. Thank you for your help anyway!

The email for support for the TensorFlow Developer Certificate is:

tensorflow-certificate-support@google.com

Thank you so much for your help Jocelyn! The team helped me solve the issue and get my certificate.
Thanks again!

I’m running into the same problems. I’ve sent an email to the same e-mail address, hopefully they’ll be able to help me as well!

I’ve found the issue, the Java error is related to file size, and managed to submit after all!

This was indeed the problem! :slight_smile: figured it out after reading into these java errors and what they usually represent. Sometimes it pays off to have worked with a high variety of programming languages :wink: Thanks though!