Error while training a Faster R-CNN object detection model: Cannot convert a symbolic Tensor to a numpy array

I was trying to train an object detection model using the Roboflow Google Colab notebook on the link below. Until Tuesday it was working properly to me but since that day, is not working any more, and I have not made any change to the code or the libraries or GitHub repositories used.

It displays the following error when I run the cell below: “NotImplementedError: Cannot convert a symbolic Tensor (cond_2/strided_slice:0) to a numpy array.”

!python /content/models/research/object_detection/

Does anyone know what has happened or how can I solve it to keep training my model?

Thanks in advance!

i found solution just use pip install tensorflow_gpu==1.15.5 instead of pip install tensorflow_gpu==1.15 and work with old version of numpy 1.18.5 which is come with tensorflow 1.15.5

same issue with me any solution??

Thanks Younis,

I tryied what you have said and it solved the previous error but now it displays de folowing one:

RuntimeError: module compiled against API version 0xe but this version of numpy is 0xd

How did you solve that one?


I have similar error but it’s work and i get my result

Are you running the same code as me? Or do you know how could we fix this problem?

I have been trying to run the program with diferent numpy versions but is still not working to me.