ESP32 TensorFlow Lite Problems

I worked with the new ESP32-S3 Development Board and an I2S microphone in order to create a simple voice recognition system. The software and firmware behind this are based on this project: atomic14 - voice-controlled-robot

This project worked flawlessly on the developer kit so I moved forward and created my own board. This schematics is inspired by the design made by Espressif: Espressif ESP32-s3 dev kit

The flashing works perfectly. I am able to use different code that uses the microphone and record sounds. No issues with programming whatsoever. But when I upload the same code that uses TFLITE (the first provided link), the code uploads, runs, and prints outputs, but the neural network does not process or output anything.

Please note that there are no differences between the code uploaded to my board and the one uploaded to the dev kit (on which everything works as it should).
There are only small differences between the two boards, but everything else (code-wise) works on my board so I am not sure what hardware issue would affect only the neural network.
The ESP32-s3 used in my design is the same one as the one on the dev kit, the only difference is the 16MB Flash in my design and 8MB Flash in the ESP32-s3 dev kit design (smaller flash memory on the board that works with the nn, compared to larger flash on the board that doesn’t work with the nn).

→ Could it be a memory problem caused by an incorrectly used capacitor that could create small differences in the voltage that powers the memory?

My schematics design:

Thank you so much for any ideas, further questions or tips!

The only thing regarding the memory that is printed out is the following message during every reset: “Loading model 12 bytes lost due to alignment. To avoid this loss, please make sure the tensor_arena is 16 bytes aligned. Used bytes 22644”. I have not been paying attention to this (for now) as the message is printed out when flashed on the dev kit as well (and the network works on there).

What happens during the runtime of the firmware is that everything works exactly as it should only the network outputs “0” for the probabilities for all of the outputs rather than real numbers.