Issue about TF recommenders sample

Hi,
When I run TF recommenders sample, it need to use Scann,code is as below:
scann_index = tfrs.layers.factorized_top_k.ScaNN(model.user_model)
if without Scann, error info will be this:

ImportError: The scann library is not present. Please install it using pip install scann to use the ScaNN layer.

But after I installed scann, error looks as this

Illegal instruction (core dumped)

version info:
tensorflow 2.8.0
tensorflow-datasets 4.5.2
tensorflow-estimator 2.7.0
tensorflow-io-gcs-filesystem 0.25.0
tensorflow-metadata 1.8.0
tensorflow-recommenders 0.6.0

Scann 1.2.5