Tensor flow doesn't work suddenly and reinstallation doesn't work

I’ve been using Tensorflow under windows environment with jupyter notebook until few days ago, it had a problem - not responded suddenly.
'import tensorflow as tf ’ gives 'ModuleNotFoundError: No module named ‘tensorflow’.
Anaconda Navogator has tensorflow installed but with the sign of python not anaconda under ‘base (root)’. I tried to unininstall tensorflow and reinstall but it continued overnight without installation. it shows ‘solving package specification’. Could someone can help this issue? Thank you. -Chuck


Welcome to the Tensorflow Forum!

It may be due to network issues or package conflicts.

You can create a virtual environment that includes the specific libraries required for the installed version of Tensorflow.

Follow below code to install Tensorflow in virtual environment:

conda create -n tf tensorflow  #Create a Virtual environment(tf)
conda activate tf              #Activate the Virtual environment
pip install tensorflow         #install Tensorflow in it

Thank you!

Thanks Chunduriv,
your suggestion solved the problem after created new VE and connected to ipykernel!

But new problem appered during code excution - kernel died at the codes of
displaying the result (with matplotlib) of CNN. Notebook stopped working and gave
" the kernel appears to have died. it will restart automatically".

I am working on this new issue now. Any thought? - Chung