TensorBoard installation and running in Mac

Hi All,

I am running my model son Mac M1 pro, I could able to use Mac GPU for all my trainings, I had installed tensor flow for Mac

But I am not able to use tensor board on Mac, Its throwing below error, It seems x86 extension for tensor board is installed instead of arm64e. Its throwing below error message when I try to laugh tensor board.

Can some help here ?

ImportError: dlopen(/Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages/grpc/_cython/cygrpc.cpython-310-darwin.so, 0x0002): tried: ‘/Library/Frameworks/Python.framework/Versions/3.10/lib/python3.10/site-packages/grpc/_cython/cygrpc.cpython-310-darwin.so’ (mach-o file, but is an incompatible architecture (have (x86_64), need (arm64e)))


Welcome to the Tensorflow Forum!

It seems that the cygrpc.cpython-310-darwin.so file is compiled for the x86_64 architecture, but your machine has an arm64e architecture.

One solution would be to uninstall and then reinstall the grpc package using a version of Python that matches your machine’s architecture.

Thank you!


Thank you for your response, I to tried reinstall for several packages and currently , running tenor board does not through any error but I am not able to see any graphs , Its showing plain white screen.

Can some one help here ?


Rajkamal Udayasuriyan