Tensorflow 1.15 installation numpy dependency

When I check the METADATA about the requirements of the Numpy version for TensorFlow(tf).

tf 1.15.0 requries 1.16.0 <= numpy < 2.0, and actually installed numpy = 1.19.2 tf 1.15.5 requries 1.16.0 <= numpy < 1.19.0, and actually installed numpy = 1.18.5

However, If I upgrade tf from 1.15.0 to 1.15.5, I need to down the numpy from 1.19.2 to 1.18.5, which is not our intention.

Is there anyone know how to avoid this big gap for numpy if I want to upgrade tf to 1.15.5? In other words, is the requirement for numpy version strictly conflict with version 1.19 when tf version is 1.15.5?


Welcome to the Tensorflow Forum!

For TF 1.15.5, we strictly follow numpy >= 1.16.0, < 1.19.0 due to ABI change.

For more details please refer here.

Thank you!