Tensorflow Certification using M1 Mac

I’ve set up PyCharm on my M1 machine as per the exam handbook’s instructions.
However, running the script below:

import tensorflow as tf
print(tf.version)

Gives this error: Process finished with exit code 132 (interrupted by signal 4: SIGILL)
From my google search, the exam’s version of TensorFlow seems incompatible with my machine.
But the handbook was very strict about the tensorflow version - otherwise the grader won’t work.

How do I resolve this?

To offer context, my macOS is version 11.4 with the M1 chip.

  • I’ve tried both intel and the apple silicon versions of Pycharm Community.
  • The command “python3 --version” successfully shows python 3.8.6 (3.8.x is required for exam)
  • I’ve tried installing the apple tensorflow for 11.x os versions.

All return the same error.

I got the same error. Although I have tried different solutions and also installed the apple fork of TensorFlow.

Update: It is finally running on my M1. Please install the release from apple/tensorflow_macros. Also, make sure that you run the script in the right arch i.e. arm64

You can’t install the exam tensorflow plugin with this

did you find any solution to set up tensorflow 2.7 in your mac book air to do the exam?

Does anyone have any updates on this? I’m able to use tensorflow-macos with python 3.8 on my M1 Macbook Pro, but the standard tensorflow package is still a no go. Am I going to have to find a different machine to use for the exam?

From the macOS tab in https://www.tensorflow.org/install/pip#macos:

Let us know if this help!

Sorry but this doesn’t really help. The linked instructions on developer.apple.com advise installing the tensforflow-macos package, which I have successfully done (and it works fine).

The documentation I have read for the certification exam indicates that the testing environment will use the vanilla tensorflow package, but there are no such packages for aarch64 Macs on PyPi (only x86_64).

Hi People,

Nice to find this thread & getting to know that I am not the only one going through this pain.

Did someone already have any working solution for this ?

I am using M1 pro Macbook with OS version - Monterey 12.3.1 and not sure how to install tensorflow 2.7.0 as the exam requires!

Regards.

1 Like

I sent in a question about this to the TF exam support and this was the answer they gave me.

“”"
We have not tested the TensorFlow Developer Certificate exam on a computer with M1.
The exam plugin will try to install TensorFlow version 2.7.
The exam will only work with the standard implementation of TensorFlow, not with tensorflow-macos.
“”"

From that response it looks like the exam configuration will fail on any newer mac that doesn’t have the intel architecture. I think it’s a bad practice to exclude such a large number of developers from taking this exam (and growing as people update or buy a new computer) but that might be the case at the moment.

If anyone has figured out some way around this it would be great to know.