Tensorflow not recognising GPU for non-admin account

I’ve been running a script that trains a neural net to perform image restoration (CSBDeep – a toolbox for CARE — CSBDeep 0.7.3 documentation)

It works fully when I run it from an admin account, but on a non-admin user account (“User” from now on) it runs on the CPU. The User account doesn’t even recognise that there is a GPU there (according to ```
from tensorflow.python.client import device_lib), but the admin account does recognise the GPU.

I have gone back to NVIDIA’s site and re-downloaded the CUDA drivers and made sure that I haven’t missed something like “install for all users on this machine”. I have made a new install of Anaconda on the User account and directly copied the environment . I have enabled permissions for the desired user in /Program Data/Anaconda3/, and it’s still not working.

I don’t understand why Tensorflow cannot see the GPU on a non-admin account. If anyone can help, I would be extremely grateful because I’m at the stage of tearing my hair out!


Could you please tell us which account (administrator or user) you used to configure the GPU? Does user account has necessary access to the CUDA directory?

What version of Tensorflow are you using? also give more information about your environment to debug further.

Thank you!