Tensorflow onMac with M1

I followed the exact instructions here Tensorflow Plugin - Metal - Apple Developer
but when I try to fit any model I get this error and model does not train…


I upgraded MacOS to 11.4 and now the model fits but I get the same error