Tensorflow2.15.0 version compatibility issue

Hi there:
I am trying to deploy tensorflow on my hpc, I can get the version of nvidia drive which is < NVIDIA-SMI 525.105.17 Driver Version: 525.105.17 CUDA Version: 12.0 > . And sametimes I’ve tried tensorflow 2.9.0 / 2.12/ 2.13.1 / 2.14.0 vailable = tf.test.is_gpu_available() is_cuda_gpu_available = tf.test.is_gpu_available(cuda_only=True) is_cuda_gpu_min_3 = tf.test.is_gpu_available(True, (3,0)) All were “False”.

When I tried pip install tensorflow[and-cuda]==2.15.0, The answer turned to the “True”, but I still keep recieve the error E external/local_xla/xla/stream_executor/cuda/cuda_dnn.cc:9261] Unable to register cuDNN factory: Attempting to register factory for plugin cuDNN when one has already been registered E external/local_xla/xla/stream_executor/cuda/cuda_fft.cc:607] Unable to register cuFFT factory: Attempting to register factory for plugin cuFFT when one has already been registered E external/local_xla/xla/stream_executor/cuda/cuda_blas.cc:1515] Unable to register cuBLAS factory: Attempting to register factory for plugin cuBLAS when one has already been registered

I don’t know if the program crashes because of this, but my program does crash the system when calling tensorflow.

If my assumptions are correct I have multiple versions of cuda on my computer right now, which path should I export the correct path to cudnn, etc. from, although I’m not sure it’s necessary.

Any answer would be helpful, cheers!

This is caused by the same global objects being linked into both tensorflow_cc, and tensorflow_framework. I reported this against 2.14, but apparently they released 2.15 anyway with the same problem. We need a bazel expert to fix this.

See my analysis in this thread: cuDNN, cuFFT, and cuBLAS Errors · Issue #62075 · tensorflow/tensorflow · GitHub

1 Like

the tensorflow versions you indicate don’t support cuda 12.0 . Try >=11.8 < 12.0. Also Tf Versions > 2.10 no longer work on windows [ FOR GPU] . Need to use WSL.