TensorflowLite error: Didn't find op for builtin opcode 'SOFTMAX' version '1'. An older version of this builtin might be supported. Are you using an old TFLite binary with a newer model?

My envs:
tensorflow version==2.0.0 with cpu
python version==3.7
os: windows10
When I trained a keras model, I used tensorflow lite converter to transfer the code into .tflite, and then use xxd tool to transfer .tflite file into C++ code, in order to deploy the model on the embedded system. But when I compiled the code, it showed the error:
Here is the part of code during the training procedure:

Thanks so much!

We see that you are using tf version 2.0.0 is not actively supported, please update to stable version tf v2.5, v2.6 and let us know if you are facing same issue.Thanks!


Thanks for your reply!
I installed tensorflow2.6.0 just now, and repeated the whole process, the error was still existed, the same as shown above, why about it?

1 Like

Please check out the installed TensorFlow version in the embedded system. Then, I would recommend using the same TensorFlow versions in the both embedded system and the model conversion.