TF object detection pip installation uncompatible

I m training Object detection model on TF.
Earlier it was working fine. but from few days I’m getting error on pip dependency resolver and unable to train my model. Also tried depreceated resolveer but error remains same.

Tried it on pip 21.0 and 20.3 versions as well. but no luck

ERROR: pip's legacy dependency resolver does not consider dependency conflicts when selecting packages. This behaviour is the source of the following dependency conflicts.
tensorflow 2.8.0 requires keras<2.9,>=2.8.0rc0, but you'll have keras 2.7.0 which is incompatible.
tensorflow 2.8.0 requires numpy>=1.20, but you'll have numpy 1.19.5 which is incompatible.
multiprocess requires dill>=0.3.4, but you'll have dill which is incompatible.
gym 0.17.3 requires cloudpickle<1.7.0,>=1.2.0, but you'll have cloudpickle 2.0.0 which is incompatible.
google-colab 1.0.0 requires requests~=2.23.0, but you'll have requests 2.27.1 which is incompatible.
datascience 0.10.6 requires folium==0.2.1, but you'll have folium 0.8.3 which is incompatible.
proto-plus 1.20.0 requires protobuf>=3.19.0, but you'll have protobuf 3.17.3 which is incompatible.

#request_help #object_detection

Do not install the Keras package, but use all Keras classes via tensorflow.keras.
If that does not help, try stepping back to Tensorflow 2.7.x. (latest 2.7)