Unable to create environments file. Path not writable. Mac M1 Chip python modules

Hi I’m trying to install TensorFlow for MAC M1 Chip OS 12.0. Post installing the application and trying to install numpy and Jupiter notebook using the below command after installing Miniforge

conda install notebook - y

conda install -c conda-forge numpy -y

I get the error

Unable to create environments file. Path not writable.
  environment location: /Users/ren/.conda/environments.txt

Executing transaction: | WARNING conda.core.envs_manager:register_env(50): Unable to register environment. Path not writable or missing.
  environment location: /Users/ren/miniforge3
  registry file: /Users/ren/.conda/environments.txt

I went to the folder and changed the permissions of the file manually it did not work

I ran the command

775 /.conda/ 

from the terminal it did not work. I removed all the folders for anaconda and Miniforge multiple times I get the same error.

Any suggestions how to get this to work?



Hi, I think this is unrelated to TensorFlow:

I tried those solutions and it did not work for me

tensorflow-metal and ’tensorflow-macos support forum is at https://developer.apple.com/forums/tags/tensorflow-metal

Thank you I closed the issue. I first went to apple dev forums. They directed me here. Closed it by watching you tube another person had the same issue like me

1 Like