Can I use google colab to work with TensorFlowTTS in August 2023?

Hi everyone!
Numerous examples, including those on the forum, suggest installing TensorFlowTTS with the following command:

import os
os.system("rm -rf TensorFlowTTS")
!git clone
!pip install .
import sys

And I get an error:

ERROR: Could not find a version that satisfies the requirement tensorflow-gpu==2.7.0 (from tensorflowtts) (from versions: 2.8.0rc0, 2.8.0rc1, 2.8.0, 2.8.1, 2.8.2, 2.8.3, 2.8.4, 2.9.0rc0, 2.9.0rc1, 2.9.0rc2, 2.9.0, 2.9.1, 2.9.2, 2.9.3, 2.10.0rc0, 2.10.0rc1, 2.10.0rc2, 2.10.0rc3, 2.10.0, 2.10.1, 2.11.0rc0, 2.11.0rc1, 2.11.0rc2, 2.11.0, 2.12.0) 
ERROR: No matching distribution found for tensorflow-gpu==2.7.0

Changing tensorflow versions (colab allows you to change only to 2.7 and higher) does not solve the problem.
I tried to install with pip

!pip install TensorFlowTTS

, but I still get the error:

error: subprocess-exited-with-error × python egg_info did not run successfully. 
│ exit code: 1 ╰─> See above for output.
 note: This error originates from a subprocess, and is likely not a problem with pip. 
Preparing metadata ( ... error 
error: metadata-generation-failed × Encountered error while generating package metadata. 
╰─> See above for output. 
note: This is an issue with the package mentioned above, not pip. 
hint: See above for details.

Can you suggest what I’m doing wrong? Or advise how to solve this problem and run TensorFlowTTS in a colab?

Hi @Moseich, In the TensorFlowTTS it was mentioned that tensorflow version required is tensorflow-gpu==2.7.0 but in the colab the minimum tensorflow version support is >=2.8. Due to this you are unable to install TensorFlowTTS in cloab. Thank You.