GPU detected skipped NUMA library missing, Detected when print Tensor (CPU)

I have followed all the steps by steps for Installation given here. When I get to the step to check if installed succefully I get tensor returned when checking for cpu(Also it returns the GPU device). And when I print list avaiable device, it skips, because of NUMA node libararies missing.

This is the result of nvidia-smi

I’m using ubuntu 22.04.2 LTS

Also I have tried installing CUDA from the following answer

Please help, been stuck with it. I have tried numerous installations, always resulting the same. Couldn’t find the solution, hence landed in this forums.

Hi @SukoonTech

Welcome to the TensorFlow Forum!

There could be an issue between incompatible version of installed Tensorflow and CUDA, cuDNN libraries or the path is not set correctly for the required libraries to detect the GPU. Please verify this with the given tested build configuration list.

As you are using Ubuntu OS, Could you please follow the step by step instructions mentioned in this link to install TensorFlow with GPU. Also please check the Hardware/Software requirements to enable GPU and set the path for the required softwares after downloading as mentioned in Step 4 and Step 6?

Please let us know if the issue still persists. Thank you.

Hi @Renu_Patel

Thanks for the help!

I’m using windows 10, WSL2 Ubuntu 22.04.2 LTS.

I did all the steps again so to instal the desired versions only as mentioned in steps. Following are the steps in the order:

  1. Installed CUDA 11.8 on windows .
  2. Installed new ubuntu
  3. installed wsl2-ubuntu cuda drivers on linux

Then followed all the step-by-step instructions from the link you shared.

Following is the output and command for GPU
python3 -c “import tensorflow as tf; print(tf.config.list_physical_devices(‘GPU’))”
2023-08-19 01:41:13.570311: I tensorflow/core/platform/] This TensorFlow binary is optimized to use available CPU instructions in performance-critical operations.
To enable the following instructions: AVX2 FMA, in other operations, rebuild TensorFlow with the appropriate compiler flags.
2023-08-19 01:41:14.141957: W tensorflow/compiler/tf2tensorrt/utils/] TF-TRT Warning: Could not find TensorRT
2023-08-19 01:41:14.892510: I tensorflow/compiler/xla/stream_executor/cuda/] could not open file to read NUMA node: /sys/bus/pci/devices/0000:26:00.0/numa_node
Your kernel may have been built without NUMA support.
2023-08-19 01:41:14.909446: W tensorflow/core/common_runtime/gpu/] Cannot dlopen some GPU libraries. Please make sure the missing libraries mentioned above are installed properly if you would like to use GPU. Follow the guide at ติดตั้ง TensorFlow ด้วย pip for how to download and setup the required libraries for your platform.
Skipping registering GPU devices…

Hi again @SukoonTech

As you have setup the Ubuntu through WSL2, could you follow this link and try again by Setting up NVIDIA® GPU support in WSL2? Please verify the instructions steps again for WSL2 mentioned in the link.