I need to help to run the tensor flow model maker in my PC using rtx 3060ti

So I am running this script train-models/train.py at main · jcnitro123/train-models (github.com) but it always use the cpu instead of my gpu I have already installed cudatoolkit 11.7 and cudnn 8.9.3 CUDA 11.x

I also tried the tutorial in youtube installing tensorflow gpu and keras gpu but when I run the python script in the jupyterlab anaconda it gives me the error

C:\Users\apere.conda\envs\envpy39\lib\site-packages\tensorflowjs\read_weights.py:28: FutureWarning: In the future np.object will be defined as the corresponding NumPy scalar.
np.uint8, np.uint16, np.object, np.bool]

AttributeError: module ‘numpy’ has no attribute ‘object’.
np.object was a deprecated alias for the builtin object. To avoid this error in existing code, use object by itself. Doing this will not modify any behavior and is safe.
The aliases was originally deprecated in NumPy 1.20; for more details and guidance see the original release note at:

1 Like

Hi @Syncro_Tech, As i can see that the code present in the screenshot and in the link is different. Could you please confirm which code you are using.

Generally the error you are facing is due to numpy version. Please try to install pip install numpy==1.23.4. Thank You.


To fix AttributeError: module ‘numpy’ has no attribute ‘bool’ error, “downgrade the numpy version to 1.23.5” or use the “astype(bool)” method instead of the “np.bool()” method.

This occurs because the “numpy.bool()” method is deprecated from the 1.24.0 version release of numpy.