Installing tfx causes “python egg_info did not run successfully”

I am trying to install tfx 1.14.0 (python version 3.10.8) and facing this error
python egg_info did not run successfully
exit code: 1

Hi @vastavtailwal, Could you please update the pip package using python -m pip install --upgrade pip and then try to install tfx. Thank You.

1 Like

I have tried to upgrade pip. It is showing another error now, resolution too deep.

Could you tell us more about your system? Mac, PC, Intel, M1, OS, virtualenv, conda, etc?

I am trying to install it in Windows 11 (Intel core i5 12th gen), WSL (Ubuntu) into a virtualenv.

I am having a similar issue with Mac M3 Max chip (Sonoma 14.4.1). To exapnd on this, I am seeing a ERROR ‘metadata-generation-failed’. pip has indicated the error lies within the package itself but oddly Tensorflow is installing just fine.

When trying to force a version ‘pip install tfx==1.14.0’ to get the latest based on the tfx documentation page I get a ‘ERROR: Could not find a version that satisfies the requirement ml-metadata<1.15.0,>=1.14.0 (from tfx) (from versions: 0.12.0.dev0, 0.13.0.dev0, 0.13.1.dev0)’.

Not sure if these are related somehow but just wanted to provide more context.

I have tried upgrading pip but still it’s showing error.
pip._vendor.resolvelib.resolvers.ResolutionTooDeep: 200000

Hi @vastavtailwal, As mentioned in this GitHub issue could you please try with this command pip install --extra-index-url --pre tfx Thank You.


Thank a lot !!! It worked.