Reptile algo training problem

I am trying to use the code from the tutorial from keras : few shot learning with reptile.(Few-Shot learning with Reptile)

My code runs for 1 hour, 1hour30, it depends, but then after a while I always get the same error:

InvalidArgumentError: Exception encountered when calling layer ‘block3b_se_reshape’ (type Reshape).

{{function_node _wrapped__StridedSlice_device/job:localhost/replica:0/task:0/device:GPU:0}} Type mismatch: actual int32 vs. expect string [Op:StridedSlice] name: sequential/backbone/backbone/efficientnetb0/block3b_se_reshape/strided_slice/

Call arguments received by layer ‘block3b_se_reshape’ (type Reshape):
• inputs=tf.Tensor(shape=(21, 240), dtype=float32)

I tried to find where it comes from, and it originates when, in the for loop, I evaluate the model to get its accuracies, at the line preds= model(images) in the keras tutorial. I have tried to debug it on a notebook, when I run the command:
preds= model(images)
in another cell (the model, images, labels are therefore still the same from when the model stopped working) it works perfectly I therefore do not understand why my for loops stops

can someone please help me?

thank you in advance! marina

Hi @Marina_Rapellini Welcome to the Tensorflow forum,

I followed the tutorial and attempted to replicate the code. Fortunately, I haven’t encountered any errors , I am attaching the gist for your reference .

Hope this helps

Thank You !