TensorFlow 2.8 released! 🥳

The TF-2.8.0 final has been released :partying_face::tada::piñata::champagne:

We also have released patches 2.5.3, 2.6.3, 2.7.1 for 59 vulnerabilities

Please see the full release notes for details on added features and changes at Release TensorFlow 2.8.0 · tensorflow/tensorflow · GitHub.

18 Likes

Hi, I am installing keras and tensorflow for the first time in R on windows machine. When creating an image database, I am getting the following error - Loaded Tensorflow version 2.8.0
Warning message:
In readLines(rf) :
incomplete final line found on ‘C:\Users\aiucxk8\AppData\Local\Temp\Rtmpu8F0Cx\file4b9819f7316b’

Also, after I installed Anaconda through install_tensorflow(extra_packages=“pillow”) and then
install_keras(), I ignored the same exact error message found in either completed installation.
Such as,
Collecting oauthlib>=3.0.0
Using cached oauthlib-3.2.0-py3-none-any.whl (151 kB)
Installing collected packages: tf-estimator-nightly, termcolor, tensorboard-plugin-wit, pyasn1, libclang, keras, flatbuffers, certifi, wrapt, wheel, werkzeug, urllib3, typing-extensions, tensorflow-io-gcs-filesystem, tensorboard-data-server, six, setuptools, rsa, pyasn1-modules, protobuf, pillow, oauthlib, numpy, markdown, idna, gast, charset-normalizer, cachetools, requests, opt-einsum, keras-preprocessing, h5py, grpcio, google-pasta, google-auth, astunparse, absl-py, requests-oauthlib, google-auth-oauthlib, tensorboard, tensorflow
Successfully installed absl-py-1.0.0 astunparse-1.6.3 cachetools-5.0.0 certifi-2021.10.8 charset-normalizer-2.0.12 flatbuffers-2.0 gast-0.5.3 google-auth-2.6.0 google-auth-oauthlib-0.4.6 google-pasta-0.2.0 grpcio-1.44.0 h5py-3.6.0 idna-3.3 keras-2.8.0 keras-preprocessing-1.1.2 libclang-13.0.0 markdown-3.3.6 numpy-1.22.3 oauthlib-3.2.0 opt-einsum-3.3.0 pillow-9.0.1 protobuf-3.19.4 pyasn1-0.4.8 pyasn1-modules-0.2.8 requests-2.27.1 requests-oauthlib-1.3.1 rsa-4.8 setuptools-60.9.3 six-1.16.0 tensorboard-2.8.0 tensorboard-data-server-0.6.1 tensorboard-plugin-wit-1.8.1 tensorflow-2.8.0 tensorflow-io-gcs-filesystem-0.24.0 termcolor-1.1.0 tf-estimator-nightly-2.8.0.dev2021122109 typing-extensions-4.1.1 urllib3-1.26.8 werkzeug-2.0.3 wheel-0.37.1 wrapt-1.13.3

Installation complete.

Warning message:
In readLines(rf) :
incomplete final line found on ‘C:\Users\aiucxk8\AppData\Local\Temp\Rtmpu8F0Cx\file4b983c836f0c’

install_keras()

Installation complete.

Warning message:
In readLines(rf) :
incomplete final line found on ‘C:\Users\aiucxk8\AppData\Local\Temp\Rtmpu8F0Cx\file4b987a57a59’

setwd(“C:/Users/aiucxk8/Documents/Cannabis StrainFeatures_R_code/imageDB/”)

In C:\Users\aiucxk8\AppData\Local\Temp\Rtmpu8F0Cx folder there are 4 rds files, a Miniconda3 installer file and a “downloaded_packages” folder. This folder contains the tensorflow 2.8.0 package’

Please help!

@Bhack any insights to suggest here?

Can you give us the exact sequence of commands that you have executed on a clean environment to install and reproduce this issue?

Generally TF with conda isn’t directly supported by TF as it is a third party packaging effort.

I think that post is a duplicate of

https://tensorflow-prod.ospodiscourse.com/t/error-in-readlines-rf/8160