Tensorflow not recognizing GPU on windows 10

I am using Jupyter Notebook on the anaconda platform. TensorFlow library is not detecting the GPU. I have RTX2070super, which is supported by CUDA. After many permutation and combinations this was my last try:
I have tried the latest version of cuda driver, which is 12.2, but found out that the anaconda does not have cudnn library for this driver. I downgraded the cuda driver to 11.0, then downloaded the cudnn and cudatoolkit which is build for this driver support. And then I installed tensorflow-gpu version 2.3. But still I am stuck with the same problem for past 2 days.
Can anyone help on this?

Hi @vinod_jha

Welcome to the TensorFlow Forum!

Which tensorflow version are you using? Because TensorFlow 2.10 was the last TensorFlow release that supported GPU on native-Windows.

Please select the compatible version of CUDA and cuDNN for the installed Tensorflow, Python as per this tested build configuration and follow the step by step instructions mentioned in this TF Install official page to install TensorFlow with GPU support.

Let us know if the issue still persists. Thank you

Thanks @Renu_Patel
I tried multiple versions of tensorflow-gpu before i came up with the above build configuration in one of your older post. Then:

  1. I downgraded my cuda build frrom 12.2 to 11.0.
  2. Downloaded CUDNN 8.0 which automatically downloaded the supported cudatoolkit package
  3. I simply used conda “install tensorflow-gpu” for conda to figure out the suitable package version so that the package does not contradict with other installed packages. It installed Tensorflow-gpu 2.3.0

But it is still not working.

@vinod_jha, Tensorflow is very specific to its supporting software libraries for GPU setup. As you have installed tensorflow version 2.3 you need to install CUDA 10.1 and cuDNN 7.6 mentioned in build configurations or can try installing the latest supported Tensorflow version 2.10 with its compatible CUDA, cuDNN, Nvidia Driver , Python version 3.7 - 3.10 in your system.

Please refer again the TF install page properly for Hardware/Software requirements and the steps/commands to install Tensorflow with GPU.


Thnx a lot Renu.
Finally it worked. I did the following:

  1. created a new environment for getting rid of any dependencies conflicts
  2. installed cuda 11.2, cudNN 8.1
  3. installed tensorflow-gpu=3.6.0

Its detecting the GPU now.


Good to know that it worked. Could you please mark the issue as solved as your issue got resolved? Thank you.

1 Like

thank you very much, it help me a lot for my works