Tensorflow Quantum Installation Error

I am new to tensorflow quantum. I’d just downloaded tensorflow 2.4.1 along with qiskit and pennylane. When I tried to install Tensorflow Quantum based on the instructions given on this link: ติดตั้ง TensorFlow Quantum, I received this installation error:

ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
tensorflow 2.4.1 requires protobuf>=3.9.2, but you have protobuf 3.8.0 which is incompatible.

For the record, all the installation is done within a Python 3.7.9 environment to avoid conflicts with other packages. This issue occurred on my Windows 10 machine.

Protobuf (to the best of my understanding) is a set of instructions that your system would use to serialize structured data. You could try updating your protobuf version from the releases page. If all else fails, try re-creating a new Python environment and install TF Quantum before any other packages

I attempted to install the latest version of protobuf 3.19.2 and this runs into more compatibility issues. I tried to create a completely new Python 3.7.9 environment and install TF Quantum first and this runs into compatibility issues with protobuf again. Not sure what else to do because it all seems to have some sort of compatibility issues. Is the instructions for downloading TF Quantum out of date by any chance?

Hi @Hatedfate thank you for raising this question. Our protobuf dependency has been made artifically tight in certain areas In the latest release version of tensorflow quantum. (TF having certain requirements that conflicted with cirq requirements). While pip does give a dependancy warning, things will still function correctly (just tested by running this tutorial on colab w/ py37 without issues) and this should be resolved in the next release version of TFQ.

Thanks for letting me know. :slight_smile: